A fix has been implemented and we are monitoring the results.
Posted May 19, 2026 - 22:39 CAT
Identified
The issue has been identified and a fix is being implemented.
Posted May 19, 2026 - 21:44 CAT
Investigating
The large-scale DDoS attack affecting parts of our upstream providers network infrastructure has resumed.
AFRIDAX may experience intermittent connectivity issues, increased latency, or timeouts while mitigation work continues. Technical teams are actively working with DDoS mitigation to manage the impact.
Posted May 19, 2026 - 21:23 CAT
This incident affected: AFRIDAX Trading (exchange.afridax.com/#/trade), Deposits (FIAT Deposits, Crypto Deposits), Withdrawals (FIAT Withdrawals, Crypto Withdrawals), and API.