Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 08, 2025 - 17:00 CAT
Scheduled
During this period, the AFRIDAX trading platform will be offline.
We are performing this maintenance to improve the overall performance and reliability of our data systems. As a new platform, regular maintenance is essential for our growth and to ensure we continue to provide you with the best possible experience, which includes necessary updates that will temporarily affect desktop, mobile, and API functionality.
We apologise for any inconvenience this may cause and appreciate your understanding as we work to improve our services.
Posted Jul 08, 2025 - 11:55 CAT
This scheduled maintenance affected: AFRIDAX Trading (exchange.afridax.com/#/trade), Deposits (FIAT Deposits, Crypto Deposits), Withdrawals (FIAT Withdrawals, Crypto Withdrawals), and API.